Installation Issue - Popup reports "Synalyze It! Pro" is damaged . . .

0 votes
asked Sep 16, 2016 in Synalyze It! by jgomberg (120 points)
Hardware: MacBook Pro (Late 2013) Retina

OS: MacOS Sierra 10.12 (16A323 - released September 15, 2016) GM version 2.

Synalyze It! Pro error: "Synalyze It! Pro" is damaged and can't be opened. Delete "Synalyze It! Pro" and download it again from the App Store.

Package download source: Apple App Store Version 2.2 (552)

Had an issue with a file requiring a hex viewer/editor. Ran Synalyze It! Pro which threw the aforementioned error message. Deleted per instruction, emptied Trash folder, downloaded the app from the App Store, and reinstalled.  Download required re-authentication to App Store to complete.

Issue is not resolved per instructions and is repeatable.

System log displays multiple repeating (incremental) entries:

Sep 16 12:58:18 Paradox com.apple.xpc.launchd[1] (com.synalyze-it.SynalyzeItPro.5552[2719]): Service exited with abnormal code: 173
Sep 16 12:58:37 Paradox com.apple.xpc.launchd[1] (com.synalyze-it.SynalyzeItPro.5552[2740]): Service exited with abnormal code: 173
Sep 16 12:58:40 Paradox com.apple.xpc.launchd[1] (com.synalyze-it.SynalyzeItPro.5552[2742]): Service exited with abnormal code: 173
Sep 16 12:58:41 Paradox com.apple.xpc.launchd[1] (com.synalyze-it.SynalyzeItPro.5552[2743]): Service exited with abnormal code: 173
Sep 16 12:58:43 Paradox com.apple.xpc.launchd[1] (com.synalyze-it.SynalyzeItPro.5552[2744]): Service exited with abnormal code: 173
Sep 16 12:58:47 Paradox com.apple.xpc.launchd[1] (com.synalyze-it.SynalyzeItPro.5552[2745]): Service exited with abnormal code: 173
Sep 16 12:58:49 Paradox com.apple.xpc.launchd[1] (com.synalyze-it.SynalyzeItPro.5552[2746]): Service exited with abnormal code: 173
Sep 16 12:58:50 Paradox com.apple.xpc.launchd[1] (com.synalyze-it.SynalyzeItPro.5552[2747]): Service exited with abnormal code: 173
. . . repeating . . .

1 Answer

0 votes
answered Sep 17, 2016 by andreas (2,180 points)
edited Sep 26, 2016 by andreas

Even after installing the latest version of Sierra, I can't reproduce it. There are some recommendations out there what can be done to fix the issue.

On http://receigen.etiemble.com/guides-diagnostic.html is explained under "Launch Issues" what store agents should be restarted.

Alternatively you can restart the computer.

Does any of this fix the problem?

Andreas

...